SSL falsch konfiguriert?

Serverhousing und dezidierte Server
Antworten
moonshadow
Beiträge: 1
Registriert: 25 Mai 2018 17:40

SSL falsch konfiguriert?

Beitrag von moonshadow » 25 Mai 2018 17:59

Hi, ich habe wie telefonisch mit dem Support darauf gewartet, dass meine SSL Verbindung endlich aktiv ist indem ich immer auf https://... gegangen bin. Jedesmal wurde mir angezeigt, dass die Verbindung nicht sicher sei und die Website wird auch nicht angezeigt sondern nur der Verweis, dass es kein Zertifikat gäbe obwohl es eingerichtet ist. Dann habe ich eine Anleitung von World4You gefunden, in der angezeigt wird, dass ich entweder einen .htacces Ordner erstellen soll oder die 3 Zeilen in den Ordner einfügen soll. Nunja ich habe in dem vorhandenen Ordner die 3 Zeilen eingefügt. Jetzt steht bei https erzwingen nun die Meldung... SSL scheint falsch konfiguriert zu sein. Bei Fragen wenden Sie sich bitte an den Support :roll: :cry: Was soll ich machen???

Hier diese gemeinte Anleitung: :arrow: https://www.world4you.com/faq/de/webhos ... eiten.html.

Achja... ich hab das Basic-SSL | Let's Encrypt Produkt. Oder wird trotz des Zertifikates kein https angezeigt was aber lt. Beschreibung schon vorhanden sein soll mit dem grünen Schloss :mrgreen:

Bitte um Info! Vielen Dank

schwaermer.net
Beiträge: 148
Registriert: 30 Aug 2007 14:58

Re: SSL falsch konfiguriert?

Beitrag von schwaermer.net » 10 Jun 2018 11:05

villeicht hilft das ja zur spurensuche bei der fehlerbehebung :wink:

ich habe sowohl für meine hauptdomain als auch meine domain-only-pakete let's encrypt zertifikate über das W4Y-kundencenter eingerichtet (die domain-only-pakete liegen in unterverzeichnissen des web-spaces meiner hauptdomain).

durch aktivieren der option
Https erzwingen
Mit dieser Option stellen Sie sicher, dass sich ein Besucher Ihrer Seite immer über SSL verbindet.

im W4Y-kundencenter wurde im root-verziechnis meiner hauptdomain eine .htaccess-datei mit folgendem code angelegt (anstatt example.org steht dort der name meiner hauptdomain).

Code: Alles auswählen

############HTACCESS W4Y START############
Order Allow,Deny
Allow from all
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTP_HOST} example.org
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
</IfModule>

#############HTACCESS W4Y END#############
trotzdem wurden einzelne sites einer forensoftware, die bei den domain-only-paketen läuft, nicht automatisch mit SSL-ausgeliefert :? ...

nachdem es im verzeichnis dieser forensoftware ebenfalls eine .htaccess datei gibt, habe ich dort folgenden code eingefügt:

Code: Alles auswählen

RewriteCond %{HTTPS} !=on
RewriteRule ^.*$ https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]
dadurch werden jetzt auch alle sites der forensoftware zuverlässig mit SSL ausgeliefert 8) 8) 8) ...

wichtig dabei ist, dass der code zwischen den <IfModule mod_rewrite.c> </IfModule> tags eingefügt wird, da es ansonsten ebenso zur fehlermeldung "SSL scheinbar falsch konfiguriert" im W4Y-kundencenter kommt :roll: ...

---------------------

ps: außerdem ist mir noch aufgefallen, dass es einige minuten dauert, bis das ganze wirksam ist, da die daten wohl noch einige zeit im cache des webservers liegen :idea: ...

pps: :arrow: :arrow: danke für die verlinkung des W4Y-support-artikels, den hatte ich erst durch diesen thread gefunden! :!: :wink:

Antworten